Announcement

Collapse
No announcement yet.

Giotto premiun plus brew / boiler issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gmk2
    replied
    A week on after replacing one of the springs in the lower section of the group that was a tad soft everything is back to normal - boiler pressure holds while brewing, brew pressure comes right up and I don't have any more leaks. Original pump still has the goods, I have previously rebuilt the control board (transformer failed) so I am calling it back in service.

    Thanks for the advice!

    Cheers,

    Andrew.

    Leave a comment:


  • Jackster
    replied
    Yep, getting there!
    We cant cant expect these things to be faultless forever. They are machines and require upkeep and repairs to keep them functioning.
    90% of the time it's just a little love needed to get them back to good condition.

    Leave a comment:


  • Gmk2
    replied
    Solenoid looks to be the issue.

    I pulled the solenoid and while it looked pretty clean there were some small particles loose inside. Gave the internals a soak in de-scaler, rinsed and put it back together. While it wasn't a full clean out (I didn't pull the T fitting out) the machine is now showing boiler pressure as holding and brew pressure climbed to 10 bar. It does seem I am chasing weak links, having gone from fill sensor, leaky vacuum, loose wiring to the P stat, the solenoid now I have a leak in the group - at least this is easier to diagnose and resolve. Getting closer!

    Thanks,

    Andrew.

    Leave a comment:


  • Jackster
    replied
    So I think...
    running the pump on brew is allowing water to go into the boiler, the pressure is dropping as the water is cold. Then the boiler ends up full, and gets pressurised by the pump resulting in it popping out the boiler pressure valve.

    I would be looking for the leak from the brew circuit into the boiler circuit. This is most likely the boiler fill solenoid, but could possibly be the hx leaking into the boiler.

    If you were allowed to mess about inside the machine, you might disconnect heating element and the boiler fill tube (hence emptying the boiler) then fire the brew button with blind fitted. Then wait to see where it's leaking...

    If it's from the boiler side of the disconnected boiler fill tube, it is the hx leaking inside the boiler.
    If it's from the fill solenoid side of the disconnected boiler fill tube, it's the fill solenoid that is leaking.

    Likely it's the fill solenoid...

    Leave a comment:


  • Caffeinator
    replied
    I'm betting dying pump and possible pressurestat. At 10 years, you either refurbish or replace the control board as well if it hasn't been done. It can be responsible for an overfill which will cause similar behaviour.

    Leave a comment:


  • Gmk2
    started a topic Giotto premiun plus brew / boiler issues

    Giotto premiun plus brew / boiler issues

    Hi there,

    My 10+ year old Giotto premium plus is having a brew / boiler issue preventing me from making coffee.

    The machine switches on, fills and stops filling, heats up gets to the 1.2 bar boiler pressure (as indicated) and will happily cycle over time.

    Running against a blind filter the boiler pressure starts to fall steadily and will drop below 0.5 bar before suddenly skyrocketing and the boiler over pressure tripping.

    The machine is running on filtered water via a fridge and is a vibe pump unit. Same water source now for many years.

    What I have done:
    • Cleaned the water level sensor, checked continuity of sensor wiring down to the controller
    • Replaced the boiler vacuum valve which had a slight leak with a new unit
    • Replaced the expansion valve which had a slight leak (the rubber mushroom was worn).
    • Tried to adjust the expansion valve to get brew pressure - however boiler OPV is going off preventing me getting up to brew pressure
    The best brew pressure I have seen as measured at the group is just over 6 bar.

    I'm finding that the boiler seems to be overfull after this issue occurs, and it seems that running the brew cycle is causing the boiler to over fill with water.

    Is the boiler fill solenoid or perhaps the one way return valve the next culprit to assess? Possibly the controller?

    Any other tips?

    Thanks,

    Andrew.
Working...
X