Announcement

Collapse
No announcement yet.

Sunbeam EM0480 problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sunbeam EM0480 problem

    Hi All,

    Im kinda new in the coffee world so be kind with my silly question... :

    Just bought a EM0480 on the recommendations of this forum and i just plugged it in and started grinding away playing with my new toy, and noticed that not much coffee was coming out so i gave it a "little tap" on the side and all this fresh coffee come out??? When i stopped the grinder when i was done i gave it a tap again and about 1 - 2 tablespoons of coffee grind come out.

    Is this normal guys because that is a lot of waste i believe and how do you know you will always have fresh grinds if there is always what i believe to be a substantial amount sitting inside the housing.

    Thanks for your help everyone!

  • #2
    Re: Sunbeam EM0480 problem

    Hi and welcome to cs!

    I always brush and tap out the leftover grinds. Maybe a teaspoon or two.  If youre beans are quite oily they may clog a little more which could be why you had so much.  Or if youre grinding very fine.

    All the best,

    sd  

    Comment


    • #3
      Re: Sunbeam EM0480 problem

      Yeah, I measure out my beans first and then rock the 480 back and forth at the finish of the grind and get about a teaspoon or 2 out as well.

      Have pulled it apart after doing this and am happy with the tiny amount left over.

      I have been doing this for over a year now and the grinder is still going strong.

      I also grind into a metal jug and get virtually no mess or clumping.

      Comment

      Working...
      X