No announcement yet.

fixing dead Iberital

  • Filter
  • Time
  • Show
Clear All
new posts

  • fixing dead Iberital

    My Iberital grinder stopped working after a cleaner "wiped it down with a damp cloth" (I think including the grinding area). If I push the switch nothing happens. It was fine the previous time I used it. It doesn't seem too likely that water got into the electrics because the power point should be on an earth leakage protected circuit.

    Any ideas on what I can do to revive it?

  • #2
    Originally posted by philipmach View Post
    It doesn't seem too likely that water got into the electrics because the power point should be on an earth leakage protected circuit.
    what does this mean? they're two separate circuits, your house has a fuse that will blow if live shorted to ground current exceeds usually 30mA (i think) which is usually used to protect people who accidentally short something out through themselves to ground as we don't have inbuilt fuses (unfortunately).
    it's unlikely that this has happened because you'd see effects on other things in the house. if a bit of water has leaked across a live to neutral/neutral to ground/live to ground link in the grinder it may have blown the internal fuse. if it's a shorted connection of some form, a fuse is going to have blown somewhere either in the house or the machine.

    if you're confident with electronics, pull it apart and check the fuse/fuses for continuity. if you find any that are open circuit, be sure to inspect the rest of the electrics for the source of the problem otherwise it might just blow again straight away once replaced.

    if it's not just fuses, maybe put up some photo's of where you think the water might have gotten in and onto what it may have leaked. for further repair yourself, without previous experience, your best bet would be to take it to a professional.


    • #3
      Thanks for the ideas. I didn't think of an internal fuse. I can check for that easily enough. I doubt very much it's anything to do with a trip switch since I plugged it into another outlet with the same result, and the other appliance I plugged in afterwards still worked. So by elimination, it's most likely something wrong in the grinder.


      • #4
        First, i would just check if the locking mechanism usually on grinders, ( to confirm that the lid is on or the grinder is in correctly)
        Every grinder i have owned wont work unless the grinder is in correctly and the lid covering the beans is on properly.
        Your cleaner might have wiped something into the switch mechanism, stopping it from working.
        If you have access to compressed air give it a blow out and try again.
        Second check for a internal fuse. Make sure it is unplugged!
        Sometimes appliances have a thermal fuse/ thermal cutout located in the active wiring of the appliance.
        Thermal fuse will have the temp cutout located on it (usually between 90-130 degrees).


        • #5
          Sight unseen, I would hazard an educated guess that wiping the grinder over with a damp cloth didnt cause any problem.

          First thing to do is to UNWIND the adjuster to a significantly coarser setting, to see if the problem is that the grinder is jammed up (it can happen for whatever reason from time to time).

          If that doesnt result in the grinder springing back to life, its for a service tech.