Announcement

Collapse
No announcement yet.

Ditting KR804 Help/Fix

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ditting KR804 Help/Fix

    Hi all,

    I seem to have an issue with my my Ditting grinder. Over the past few weeks I would turn it on at certain grind settings and unlike normal it would make a little murmur and with a small switch of the dial it would start. However last night this happened again but instead of starting it gave a small little pop and i'm pretty sure its now not working.

    So my question is what might this be but more importantly can anyone give me some advice on it and where i might be able to to take it to have it looked at?

    I'm in Melbourne.

    Kind regards,

    Chris

  • #2
    Originally posted by coffeechris View Post
    Hi all,

    I seem to have an issue with my my Ditting grinder. Over the past few weeks I would turn it on at certain grind settings and unlike normal it would make a little murmur and with a small switch of the dial it would start. However last night this happened again but instead of starting it gave a small little pop and i'm pretty sure its now not working.

    So my question is what might this be but more importantly can anyone give me some advice on it and where i might be able to to take it to have it looked at?

    I'm in Melbourne.

    Kind regards,

    Chris
    G'day Chris

    I would start by giving the thing a really good clean. The first bit sounds like dirt in a pot somewhere, the last bit sounds like a fuse has finally "popped". A bit of well guided circuit cleaner may help the first, a multimeter can help find the second (or a human eyeball...).

    An old one I fixed stopped because the adjuster was so full of grounds it triggered some safety switch (overload? too long ago to recall).

    After that, if still no joy I would consider a repairer via CS sponsors.

    Given the Dittings industrial nature, they are actually quite easy to work on. Also, these days I presume the manual is online.

    TampIt
    Last edited by TampIt; 11 January 2015, 02:19 AM. Reason: Typo - new keyboard seems to miss keystrokes.

    Comment


    • #3
      Thanks Tampit, after sitting at work on friday i remembered a few things to try. I went home Friday and looked to see the red button on the base had gone off so i reset that. Turned the grinder on only to find it was still stuck. So i took the grinding chamber apart cleaned it out (it wa pretty choked up) put it back together and was back to normal. In doing so i saw the discs are worn so im ordering some new ones fir the near future. You are correct in saying they are easy to work on, easy to pull apart also.

      All that aside thanks for your reply and thoughts on the problem. Much appreciated

      Chris

      Comment

      Working...
      X