Announcement

Collapse
No announcement yet.

Mazzer Mini Manual Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mazzer Mini Manual Help

    Hi CS members

    I have just completed a disassembly clean and reassembly of my grinder and it is not grinding fine enough as it was immediately prior to the job. Any suggestions welcomed. OK this is what I have done.

    1. Removed the hopper, upper burr carrier and cleaned both burrs with a stiff brush. The burrs appear in good nick and have probably done less than 150kg. Vacuumed out all the debris.

    2. Carefully reassembled upper burr carrier. With grinder off wound it down until it was tight and backed it off half a turn. Turned grinder on and slowly turned adjustment to fine until I could hear the burrs touching. Then wound it back a fraction until the burrs were quiet. Put back hopper and some beans in and ground them. First time nothing came out and the whole beans just pop corned around. Repeated the disassembly and reassembly process several times with same result. Eventually it started grinding but the result was a very course grind with a gushing pour.

    3. I am baffled. I wind the adjustment collar fine to the point where the burrs can be heard touching then back it off the smallest amount until the noise just stops and end up with a very course grind that gushes when making a brew.

    Thanks

  • #2
    I found this document yesterday and think if you follow the instruction on the last page, it may help.
    I have not yet had to dismantle mine so I cannot help from my experience.

    A copy of this Doc has been moved to the Grinder Documentation Section
    Attached Files
    Last edited by Javaphile; 2 January 2016, 11:39 PM. Reason: Add note

    Comment


    • #3
      Most likely coffee debris in the burr carrier threads limiting burr travel. Best start again and make sure all is spotless.

      Comment


      • #4
        Thanks for the suggestions. I will redo it later and report back

        Comment


        • #5
          Morning MB.

          I've owned a Mazzer Mini for about 5 years and clean it in a similar manner to what you have describe every few months, only difference being as Toorakwa suggests, I clean the thread thoroughly and lubricate it with a pressure pack silicon lube, have not experienced the problem you are having.

          Also after roughly 300 kg replaced the burrs about a month ago with a new set (oem) this made quite a difference to the grind speed, though little affect on what is in the cup.

          Good luck with solving your problem, let us know what it was when you find the solution.

          Comment


          • #6
            Hi MeanzBeanz, May be you have buggered the burrs buy what you say you did in #2- Turned grinder on and slowly turned adjustment to fine until I could hear the burrs touching. Then wound it back a fraction until the burrs were quiet.

            Comment


            • #7
              Update. Went back to the beginning and pulled it apart and thoroughly cleaned everything again including the burr carrier
              threads. There was not a grain of coffee left by the time I finished. Reassembled and adjusted and all is well. Just enjoying a morning brew as I type this.

              Many thanks to all who replied.

              Comment


              • #8
                Great stuff MB, pleased it all worked out well.

                Comment


                • #9
                  Same issue - additional thought

                  I had this same issue, on a Mazzer mini with doser. I'd tightened the grinder adjustment ring/top burr carrier/top burr carrier until it stopped, backed it off a bit so it would turn - but super coarse grind. Then I'd try and tighten it further and I'd get no motion (for a second before I'd flick it off again). So I knew I couldn't turn it any further - it was close to fully screwed down but no motion.

                  I retried cleaning and re-assembling twice more - third time was a charm.

                  So, many thanks for the instructions - some additional points I'd note because I think this is pretty easy to have happen.
                  - The burr carrier thread is pretty fine - thread pitch must be less than a mm, so i reasoned it wouldn't take much to stop it screwing down by an entire revolution.
                  - When I looked at the gap between the top of the grinder body and the bottom of the adjustment ring I was sure the gap was bigger than it had been before dissassembly - so I suspected something was stuck in there. Similarly when I was looking into the re-assembled burrs - the gap between them just looked bigger than it should
                  - It's a single thread, so there is only one point you could engage the thread, and I think as a result you should end up with the rod in the adjustment ring back in the same location you started. If you could somehow rotate the ring relative to the burr carrier/collar (maybe you can ?) you may end up at a different location.
                  - Pushing down on the centre collar compresses the springs and allows you to turn the burr carrier more easily. This allows you to more easily feel when it's reached the end of it's rotation.

                  So, before you dissassemble, take a note of the gap between the top of the grinder and the collar - on mine it's around 3mm - maybe insert a bit of folded paper - and you'll know how far the collar should screw down when you re-assemble it. If it screws down and there is a bigger gap than that, screw it apart, reclean and try again !

                  Comment


                  • #10
                    Originally posted by alisters View Post
                    I had this same issue, on a Mazzer mini with doser. I'd tightened the grinder adjustment ring/top burr carrier/top burr carrier until it stopped, backed it off a bit so it would turn - but super coarse grind. Then I'd try and tighten it further and I'd get no motion (for a second before I'd flick it off again). So I knew I couldn't turn it any further - it was close to fully screwed down but no motion.

                    I retried cleaning and re-assembling twice more - third time was a charm.

                    So, many thanks for the instructions - some additional points I'd note because I think this is pretty easy to have happen.
                    - The burr carrier thread is pretty fine - thread pitch must be less than a mm, so i reasoned it wouldn't take much to stop it screwing down by an entire revolution.
                    - When I looked at the gap between the top of the grinder body and the bottom of the adjustment ring I was sure the gap was bigger than it had been before dissassembly - so I suspected something was stuck in there. Similarly when I was looking into the re-assembled burrs - the gap between them just looked bigger than it should
                    - It's a single thread, so there is only one point you could engage the thread, and I think as a result you should end up with the rod in the adjustment ring back in the same location you started. If you could somehow rotate the ring relative to the burr carrier/collar (maybe you can ?) you may end up at a different location.
                    - Pushing down on the centre collar compresses the springs and allows you to turn the burr carrier more easily. This allows you to more easily feel when it's reached the end of it's rotation.

                    So, before you dissassemble, take a note of the gap between the top of the grinder and the collar - on mine it's around 3mm - maybe insert a bit of folded paper - and you'll know how far the collar should screw down when you re-assemble it. If it screws down and there is a bigger gap than that, screw it apart, reclean and try again !
                    This all makes removing the top burr carrier to clean the Mazzer sound like a difficult task, when in fact it really is quite straight forward, spotlessly clean threads and a bit of light lube is the solution to easy reassembly.

                    Comment

                    Working...
                    X