Announcement

Collapse
No announcement yet.

Compak k3 touch not grinding fine since grinding beans coarse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compak k3 touch not grinding fine since grinding beans coarse

    I recently ground around 1kg of beans on a coarse setting for plunger coffee for a large group of people to last a week. Returning the setting on the grinder to about my espresso grind setting it continues to grind coarse. I thought I had moved it slow enough and while it was running but I guess either I did it too fast or incorrectly. I've done this quite a few times in the past without any problems.
    I need to move the grind setting a long way into the fine area before I get a finer grind and it seems either coarse or too fine and hard to get right now.

    Before I start taking the machine apart for a good clean is there anything I can more easily instead?

  • #2
    Thanks Paul, tried the above and it didn't make any difference. I have had to move the grinder dial about a 1/3 of a turn more to the fine setting to get the same grind.

    Comment


    • #3
      K3 isn't designed to grind 1kg of beans. You'll find the duty cycle of the motor is 2 minutes on then 10 minutes off.

      Comment


      • #4
        I bet the motor (and possibly the capacitor) was a 'little' warm after this effort...

        Mal.

        Comment


        • #5
          I didn't do grind it continuously and don't recall it heating up too much. I'll have a crack at cleaning it this weekend when I get some spare time.

          Comment


          • #6
            If you push the Duty Cycle too much, the motor/capacitor will definitely heat up.
            Might not feel it through the grinder casing for a while though, and damage might already have started...

            Mal.

            Comment

            Working...
            X