Announcement

Collapse
No announcement yet.

Avice sunbeam em0480

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avice sunbeam em0480

    Hi i have a 0480 grinder 1 year old ,roast my own beans, usually 3 grinds per day average when i frst got it i was grinding for espresso on 7/8, in the last few weeks i was down to 3/4 so order a shim kit from sunbeam which i received. I followed instructions and placed a shim in and put back together, test grined on 12 and it just chewed the beans but nothing came out ran machine for 30 seconds but nothing pulled apart and cleaned machine tryed again on 9 and same thing ,pulled apart and cleaned and removed shim ,so it was back to factory setting ground some coffee on 6 and chocked Silvia moved to 12 as per recommendation in instructions and pulled a short not a good coffee but extraction times and weight out where close .
    What happened was something not right from new and slowly got worse and me reassembling it fixed it ,as anyone else had similar?
    Thanks Ross

  • #2
    Gday Ross
    I had read a post on here where a member had experienced a similar issue... if i remember correct, there wasn't enough room for the ground beans to travel through and were just getting mashed up.
    Glad for you that it self-corrected. I have the em0480, its a good enough grinder, a little inconsistent but gets the job done until i save up the money to get a better one. I've been looking at the niche zero but its a big jump.

    Comment

    Working...
    X