Results 1 to 9 of 9

Thread: Bad taste from my Siliva

  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    13

    Bad taste from my Siliva

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    hello coffee friends! Just of late the lattes Im making from my Silvia seem to have a weird aftertaste finish on them.

    I have done a descale and cleaned the group head etc not sure what else to do to try and recitify this. Any help would be much apprecitiated! :)

  2. #2
    Senior Member David8's Avatar
    Join Date
    Oct 2011
    Location
    Annerley, QLD
    Posts
    559

    Re: Bad taste from my Siliva

    What sort of taste exactly? Have you changed anything in your routine? Beans? Milk? Technique?

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    13

    Re: Bad taste from my Siliva

    Hi David,

    Thanks for the reply. its more a kind of bitter/acidic finish? no big taste.

    No I havent changed anything at all in my routine, hope its not my tastebuds!

  4. #4
    Senior Member saoye's Avatar
    Join Date
    Jul 2011
    Location
    Adelaide
    Posts
    1,006

    Re: Bad taste from my Siliva

    Did the taste come before or after the descale?

  5. #5
    Junior Member
    Join Date
    May 2011
    Posts
    13

    Re: Bad taste from my Siliva

    was there before and that was why I did the descale to see if it would clear it up

  6. #6
    .
    Join Date
    Aug 2004
    Posts
    2,312

    Re: Bad taste from my Siliva

    Descaling does absolutely naught for taste.

    You will need to advise whether the strange taste is to do with the coffee brew, OR the steamed milk.

    So.....:
    a) brewed coffee aftertaste? or
    b) steamed milk aftertaste?

    After that, someome may be able to help a little further.

  7. #7
    Junior Member
    Join Date
    May 2011
    Posts
    13

    Re: Bad taste from my Siliva

    its the coffee that tastes wrong

  8. #8
    .
    Join Date
    Aug 2004
    Posts
    2,312

    Re: Bad taste from my Siliva

    ok.

    Next step:

    Silvia has only 1 "circuit so whether you take the water from the group or from the steam pipe doesn madder. So, relieve some hot water from the steam pipe and taste. Is it ok?

    May as well also try some water from the group, just to compare. It cant help having a slight flavour of coffee oils.

    The water from the steam arm should taste kind of oddly "sweet" but clean, possibly slightly "metallic".

    If that is ok, then you are down to checking your coffee supply.

  9. #9
    Senior Member
    Join Date
    May 2010
    Location
    Sydney North Shore
    Posts
    1,325

    Re: Bad taste from my Siliva

    Behmor Brazen - $249 - Free Freight
    How about trying some different coffee beans?

    Barry.



Similar Threads

  1. Siliva V3- Coffee tasting bad lately
    By dman777 in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 2
    Last Post: 6th June 2012, 09:26 AM
  2. Siliva PID not working!
    By Kasa in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 9
    Last Post: 21st September 2008, 04:59 PM
  3. [m]: Siliva PID not working!
    By TC in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 0
    Last Post: 8th September 2008, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •