Results 1 to 5 of 5

Thread: Problem with coffee coming out the top of the portafilter when brewing on my 6910

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    11

    Problem with coffee coming out the top of the portafilter when brewing on my 6910

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hey, guys.

    This has only started recently, but is getting annoying.

    The coffee isn't ground too finely and I am not tamping the ground beans too hard, yet I get a steady flow from the top of the portafilter and into the cup.

    Anyone have any idea why this is happening? Beans are home roasted to about a 7.

  2. #2
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,591
    group head seal need replacing?

    I presume the portafilter seems to lock in as normal.

  3. #3
    Senior Member coffeechris's Avatar
    Join Date
    Jul 2011
    Location
    Melbourne
    Posts
    721
    Group seal sounds like it needs replacing

    Chris

  4. #4
    Junior Member
    Join Date
    Nov 2011
    Posts
    11
    Yes, awesome. Thanks, Barry, and, Chris.

  5. #5
    Senior Member GregWormald's Avatar
    Join Date
    Jul 2007
    Posts
    2,286
    Behmor Brazen - $249 - Free Freight
    Most likely the group head seal.

    Could also be some grounds imbedded in the seal--try a really good clean.

    Could also be the portafilter is over full--try reducing the dose a bit and check.

    Greg



Similar Threads

  1. EM 6910 Naked portafilter
    By Brettus in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 1
    Last Post: 17th March 2012, 11:47 PM
  2. La Mar portafilter problem
    By mmmcoffee in forum Brewing Equipment - Extreme Machines ($3000+)
    Replies: 5
    Last Post: 7th August 2010, 12:59 AM
  3. 6910 pucks no longer coming away cleanly
    By Ali in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 10
    Last Post: 26th January 2009, 11:04 AM
  4. Gaggia Classic brewing group and hot water problem
    By aleph in forum Brewing Equipment (non-machine specific)
    Replies: 9
    Last Post: 15th December 2006, 04:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •