Results 1 to 8 of 8

Thread: grinder not working

  1. #1
    Junior Member
    Join Date
    Oct 2010
    Posts
    14

    grinder not working

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi There, i have a Gino Rossi RR45 grinder and it is not grinding. It was working fine last night. Any ideas

  2. #2
    brett230873
    Guest

    Re: grinder not working

    Mate... sad news. You will have to provide more info than that! Is it plugged in, switched on and is the GPO working (no fuse blown)?

    Does the motor hum ie power but no shaft rotation?

    Hopefully AM will be along shortly with a real checklist of things and remember before you rip it open, 230V kills! ;)

  3. #3
    Senior Member
    Join Date
    Jan 2007
    Posts
    100

    Re: grinder not working

    I think before anyone can give any suggestions youll need to provide more info. When you say not grinding - is the motor running, but the burrs not turning (jammed perhaps?); or maybe the burrs are turning but its not producing any ground coffee (eg a blockage?); or is it totally dead (ie nothing at all happens when you turn it on - motors died?).
    Edit: beaten to it.

  4. #4
    Junior Member
    Join Date
    Oct 2010
    Posts
    14

    Re: grinder not working

    Yes sorry guys not much info. the power works and the burrs turn but it is not grinding anymore, i have even turned it clockwise as far as it will turn but still no grind. Regards, gary

  5. #5
    Senior Member
    Join Date
    Dec 2007
    Posts
    921

    Re: grinder not working

    So no motor noise? Make sure that the hopper is completely in and that the lid for the doser is on properly, next try the cut off switch in the dosing chamber (the one behind the rubber disc) it may have become stuck. They are the two most obvious reasons I can think of off the top of my head.

    Brett

  6. #6
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: grinder not working

    take the burrs right out of the top and tell us whats in there ?

    I kind of was thinking you got something like sticky coffee grinds all jammed up in there blocking the throat / burr area of it ?

    been grinding any "flavoured beans " or anything weird in it?

    take out the hopper throw in some beans and grind em and tell us what happens to them?

  7. #7
    Junior Member
    Join Date
    Oct 2010
    Posts
    14

    Re: grinder not working

    Thank you very much everyone. Yes i pulled apart the burrs and they were very sticky with coffee oils, etc. I soaked them in coffee cleaning chemical for an hour and cleaned up everywhere inside where the burrs sit. Presto grinding fantastically again. Thank god! I can have my morning coffee YA! Cheers again. Gary

  8. #8
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: grinder not working

    Quote Originally Posted by 6267756E67626969060 link=1287629084/6#6 date=1287656187
    Yes i pulled apart the burrs and they were very sticky with coffee oils, etc.
    Dont use pre flavoured beans from GJ or others ;D

    Seen many grinders clogged with either Flavoured beans OR rancid oil from lack of maintenance.

    If ya lucky; some time you get to buy a non working system cheep and a bit of elbow grease can work wonders.



Similar Threads

  1. Breville Smart Grinder stopped working
    By beverageking in forum Grinders
    Replies: 1
    Last Post: 12th October 2012, 09:58 AM
  2. Lelit Combi- Grinder not working
    By darkenedhue in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 3
    Last Post: 29th December 2010, 10:02 PM
  3. can any1 help grinder not working?
    By johnd1g in forum Grinders
    Replies: 2
    Last Post: 22nd October 2008, 07:48 PM
  4. EM0480 grinder setting not working
    By Not_Perfect in forum Grinders
    Replies: 11
    Last Post: 20th April 2008, 02:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •