Results 1 to 14 of 14

Thread: Compak K10 Issue since service - Assistance appreciated

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Compak K10 Issue since service - Assistance appreciated

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi All,

    Sorry to bother you but I just got my grind and espresso machine serviced today and upon receiving the grinder back Ive found that the Grind plate/\/regulator was pointing towards the back rather than out the front as it had previously been.
    This lead me to believe perhaps it was an oversight by the technician and put on back wards but upon removing the plate it appears I cannot get the grind to change no matter what.
    Ive gone through the manual a few times now and cannot seem to grasp whats wrong. Ive attached two photos below with hopes that may help this community in hopefully identifying the issue.

    Any help would be appreciated and I thankyou for taking the time to read this.

    - Jason






    im unable to change the grind setting.

  2. #2
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Compak K10 Issue since service - Assistance appreciated

    i would return it to the service provider in the morning

    dont risk more damage

    if you paid good money .........

  3. #3
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: Compak K10 Issue since service - Assistance appreciated

    Hello Jason,

    Your grinder was returned set to approximate espresso grind. You will need to adjust your grind according to your coffee and your technique.

    As to the collar, you will note that there are 3 metric screws and in fact the collar can go on any way you like, so long as the stop functions appropriately. If you have a favourite position, bring it in and Ill face it whichever way you like.

    The collar will be fairly tight as its impossible not to get some debris in the thread when its dismantled. An hour was spent removing as much as humanly possible. It will improve in time.

    Finally, a reminder that grind is a fluid thing, not fixed. *You do need to make grind adjustments in response to a whole host of factors.

    Chris

  4. #4
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Re: Compak K10 Issue since service - Assistance appreciated

    Thanks for the response Chris.

    I dont mind which way around it is, my issue is that it doesnt seem to turn/\/adjust at all. Its literally stuck and doesnt budge. It used to just smoothly rotate from fine to course but its feels like its not fused solid if that makes any sense? Any ideas?

  5. #5
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Re: Compak K10 Issue since service - Assistance appreciated

    I just went and gave it a bit more power with my hands and it does infact move but it is so jammed theres not a hope in hell I can achieve any sort of fine adjustment with it in this state.

    Is there a way I can clean it further, where exactly should I be focusing on cleaning?

  6. #6
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Re: Compak K10 Issue since service - Assistance appreciated

    I just got some paper towel and have tried to remove as much coffee debris as I can and used a vacuum cleaner which seems to have improved it to being usable but there is still no way my wife would be able to adjust the grind which is disappointing.

    Any suggestions on cleaning methods?

    Thank you everyone for taking the time to help me. Its greatly appreciated.

  7. #7
    Senior Member
    Join Date
    Nov 2010
    Posts
    448

    Re: Compak K10 Issue since service - Assistance appreciated

    Quote Originally Posted by 5B194A425A5D4C484D50290 link=1297934820/5#5 date=1297937023
    Any suggestions on cleaning methods?
    I have one of these I use in my line of work:.



    Great for this kind of thing.

    Unfortunately the only "Giotto" I can afford :(

  8. #8
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Re: Compak K10 Issue since service - Assistance appreciated

    Thanks for the feedback. I ended up cleaning it with many many pieces of power towel and now is is turning smoothly.

    My issue now is that the collar is wound back down into place the finest setting is quite course. Ive obviously done something wrong when screwing it back down or cleaning the collar.

    Im sure its an obvious thing. Anyone know off the top of the head what I may have done wrong?

  9. #9
    Member
    Join Date
    May 2009
    Posts
    78

    Re: Compak K10 Issue since service - Assistance appreciated

    If your grinder is stuck simply re-zero it.

    Unwind the burr carrier (clockwise).
    Vacuum out debris and clean burrs.
    Wind burr carrier (counter-clockwise) all the way down until burr touches burr.
    Unwind by half a full rotation.
    Dial in grinder from this setting.

  10. #10
    Junior Member
    Join Date
    Feb 2009
    Posts
    15

    Re: Compak K10 Issue since service - Assistance appreciated

    That worked great. Thanks The Espresso School greatly appreciated.

  11. #11
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: Compak K10 Issue since service - Assistance appreciated

    Well done Jason.

    Sounds like I owe you a coffee :-[

    Thanks for giving Jason a hand Dave. I missed the later posts for a bit as I was out.

    Glad all is well.

    Cheers

    Chris

  12. #12
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Compak K10 Issue since service - Assistance appreciated

    Quote Originally Posted by 2B693A322A2D3C383D20590 link=1297934820/9#9 date=1297940969
    That worked great. Thanks The Espresso School greatly appreciated.

    Remember as tempting as it might be at times... NEVER wet lube as it will attract coffee dust and bind like tar *:D

    I have see a couple of units, where the fix has been to use a "BIT" ... Just a dash of carbon powder, not unlike the stuff ya use in locks. *The problem is it is possible to go OVERBOARD.

    HINT: *A good old soft lead pencil or even a carpenters pencil *and just draw a few lines on the threads will help and is about all ya need *;)

  13. #13
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: Compak K10 Issue since service - Assistance appreciated

    Quote Originally Posted by 143B32302718343B34323038303B21550 link=1297934820/11#11 date=1297943544
    NEVER wet lube as it will attract coffee dust and bind like tar
    Agreed AM. Why they put them together with wet lube I dont know ::)

    Mazzer uses what I think is lithium grease as well. Every pull down is a royal pain in the butt....

    C

  14. #14
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    16,869

    Re: Compak K10 Issue since service - Assistance appreciated

    Since acquiring the Kony, Ive been using the occasional dash of a Dry Teflon Lube. As with the Graphite Powder, only a very small amount is needed otherwise the excessive build-up can cause binding to occur.

    The Teflon Lube dries colourless or at most, a very faint pearly white sheen. Either way, it makes for a cleaner job when disassembling/assembling the upper burr carrier when cleaning out the grinder.

    Mal.



Similar Threads

  1. Compak K8 Grinder Doser Issue
    By seng888 in forum Grinders
    Replies: 1
    Last Post: 23rd October 2010, 06:10 PM
  2. All Assistance appreciated!?!
    By bazzah in forum Brewing Equipment - Extreme Machines ($3000+)
    Replies: 12
    Last Post: 17th December 2007, 04:53 PM
  3. [m]: All Assistance appreciated!?!
    By Dimal in forum Brewing Equipment (non-machine specific)
    Replies: 0
    Last Post: 15th December 2007, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •