Results 1 to 4 of 4

Thread: Sunbeam em0480 problems

  1. #1
    Junior Member
    Join Date
    Apr 2012
    Posts
    1

    Sunbeam em0480 problems

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi i recently got a sunbeam emo480 and I cant notice a difference between the finest and most coarse grind. Should I be able to? When I take off the bean hopper and adjust the grind coarse ness the burrs do not move

  2. #2
    Senior Member
    Join Date
    Jun 2011
    Posts
    290

    Re: Sunbeam em0480 problems

    When adjusting the grind have you got it runnng?

  3. #3
    Senior Member
    Join Date
    Sep 2011
    Posts
    395

    Re: Sunbeam em0480 problems

    Have you made sure that you have put the grinder together properly? its a common catch for people to put the burr and collar on in the wrong order

  4. #4
    Junior Member
    Join Date
    Apr 2012
    Posts
    1

    Re: Sunbeam em0480 problems

    Rather then starting a new topic, my problem is similar, but I might be able to help the original poster.* Firstly, the instruction manual with the em0480 is not really clear as to how to put the machine together.* I struggled with this.* I found this video of a guy reassembling his after cleaning, which might help if your problem is not quite having it assembled right

    youtube.com/watch?v=Kbu5JRH9QbU

    Apologies its not an active link, apparently I need to post more then 5 times before that can happen.

    My problem:
    I have had my em0480 for 18 months and usually grind a single shot each day for my morning coffee.* I decided to give it the first clean the other day, but similarly had troubles putting it back together.* Now I cant get my grind fine enough, even on the finest setting.* I did notice that one of the ears on the top burr, has snapped off (might of happened when I was diassembling or being a bit forceful when trying to reassemble).

    My guess is that this is my problem with not getting a fine grind as what I can tell, when you adjust the grind setting, the ears screw the top burr closer down to the bottom burr and with one missing, it just cant screw tight enough.

    The other reason may be that as I cleaned the machine for the first time, this might have highlighted the burr wear, which means that I need to add a spacer under the bottom burr.

    I really dont have much of an idea as to the workings of the machines, so any opinions or guidance on this would be greatly appreciated.* (I am very jittery without my coffee this morning).




Similar Threads

  1. Replies: 131
    Last Post: 23rd January 2017, 11:14 AM
  2. sunbeam em6910 problems
    By margo in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 3
    Last Post: 30th July 2011, 08:24 AM
  3. Problems with EM6910 or EM0480 ??
    By ken007 in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 36
    Last Post: 24th March 2008, 11:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •