Results 1 to 8 of 8

Thread: Breville BCG800 not grinding

  1. #1
    Junior Member
    Join Date
    Sep 2013
    Posts
    11

    Breville BCG800 not grinding

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Just unpacked a new Breville DB and BCG800 grinder, and after walking through the set up am disappointed to find the grinder, well, simply does not grind. Lots of noise and (apparent movement), but nothing (or very little) coming out the bottom. Back to Breville I assume unless anyone thinks there might be something obvious that I have missed, but it is all pretty idiot proof!
    Andy

  2. #2
    Senior Member
    Join Date
    May 2010
    Location
    Sydney North Shore
    Posts
    1,326
    Welcome to CoffeeSnobs andyD.

    I would remove the bean hopper from the top and check that the top burr is completely installed as far clockwise as it can go with the red arrow on the top burr carrier pointing close to the red arrow after lock.

    If you can’t get it to work, give Breville a phone call and take it back to where you bought it from for a replacement.

    Barry

  3. #3
    Senior Member
    Join Date
    Feb 2012
    Location
    Central Coast NSW
    Posts
    684
    Quote Originally Posted by Barry_Duncan View Post
    If you can’t get it to work, give Breville a phone call and take it back to where you bought it from for a replacement.

    Barry
    Exactly, it should work straight out of the box. I would not even bother calling breville. Just return to place of purchase, it will be classed as DOA and replacement given, usually no questions asked.

  4. #4
    Junior Member
    Join Date
    Sep 2013
    Posts
    11
    Thanks Barry. Yeh, I think it is locked in. Taken it in and out a few times. Canít see anything amiss. Will need to ring Breville on Monday I think.
    A

  5. #5
    Junior Member
    Join Date
    Sep 2013
    Posts
    11
    Thanks. All sorted. I returned the grinder to the retailer this morning and after confirming it simply wasn’t working, they replaced it without any trouble. I have been trying to dial-in the Breville DB and BCG800 since I got home, without a lot of success I might add, but I suspect that is the user not the tools. I have also bought some fresh beans from a local roaster here in Canberra (in Braddon) for the first time, and I think they are behaving quite a bit differently from the bulk supermarket beans I have been using previously (Lavazza).
    Cheers
    Andy

  6. #6
    Senior Member
    Join Date
    Aug 2013
    Location
    Adelaide, South Australia, Australia
    Posts
    208
    Quote Originally Posted by andyD View Post
    Thanks. All sorted. I returned the grinder to the retailer this morning and after confirming it simply wasnít working, they replaced it without any trouble. I have been trying to dial-in the Breville DB and BCG800 since I got home, without a lot of success I might add, but I suspect that is the user not the tools. I have also bought some fresh beans from a local roaster here in Canberra (in Braddon) for the first time, and I think they are behaving quite a bit differently from the bulk supermarket beans I have been using previously (Lavazza).
    Cheers
    Andy
    Not sure which machine you have, I use this grinder with a breville dual boiler, and the reference starting point on my grinder is grind pointer is pointing to just under the e on the word espresso +- 8-9 from the end. The dose is almost all the way to left +- 2 bars from left.

    But that is very much dependent on the machine

  7. #7
    Junior Member
    Join Date
    Sep 2013
    Posts
    11
    Quote Originally Posted by ggoosen View Post
    Not sure which machine you have, I use this grinder with a breville dual boiler, and the reference starting point on my grinder is grind pointer is pointing to just under the e on the word espresso +- 8-9 from the end. The dose is almost all the way to left +- 2 bars from left.

    But that is very much dependent on the machine
    Thanks. I am also using a new Breville DB and after a bit of trial and error yesterday, I think my settings are pretty close to yours.

  8. #8
    Senior Member
    Join Date
    Aug 2013
    Location
    Adelaide, South Australia, Australia
    Posts
    208
    Quote Originally Posted by andyD View Post
    Thanks. I am also using a new Breville DB and after a bit of trial and error yesterday, I think my settings are pretty close to yours.
    Here is a video I made. Try not laugh to much. I'm still a noob.

    https://www.youtube.com/watch?v=EvzRJnd4Vpk



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •