Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By demq

Thread: Choking issues with an old Mini-E

  1. #1
    Member
    Join Date
    Sep 2011
    Posts
    33

    Choking issues with an old Mini-E

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello All,

    I got my hands on a used (for many years) Mini-E that was choking (motor stalling) when the grind was made fine enough for espresso. It previously worked well for years within the same setup, and the setting it was on was far away from the "powder" stage that usually clogs this type of grinders. The burrs would actually start turning and then stop, so I suppose it is not the capacitor. Pressing the grind switch further would only activate the relay (clicking sound), but the motor would not turn. Unwinding the collar to make it way coarser would not help clear it and the motor would stay stuck.

    It was in a neglected state when I got it, and spent a lot of time cleaning it from the nasty coffee oils built up in the hopper, in the doser chute, etc. Took off the burrs and cleaned everything nicely. I noticed a hardened build-up of coffee behind the little metallic doser screen (grill) that I cleaned up and could see that there was nothing left in the grinding chamber either. Nevertheless, after all the TLC the grinder would still get stuck, and the only way to make it work was to remove the doser screen. Once working it produces decent quality grind.

    I know that removing this screen is customary among people who worry about grind retention, but it worries me that this issue might be related to the motor getting weaker/dying (thus not being string enough to push the grins out with the screen in). Any advice what to do in this kind of situation? Is it the coiling in the motor's stator? I've heard motors are hard to replace in Mazzers, but where do you find a new one to swap in to begin with (I have not found it at the usual parts retailers), and how do you do it? The tech that had looked at it has told the previous owners that it was on its way out and should be replaced.

    Cheers!

  2. #2
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    16,957
    G'day mate...

    Sounds like the Start/Run Capacitor is cactus. Should be able to get a new one from any of our Site Sponsors...
    Just because it starts and runs, doesn't mean that the cap. isn't buggered, it probably no longer has the same capacitance that it had originally.

    So long as you don't observe the expensive blue smoke being discharged from the grinder, the motor is most likely Ok. I suppose it is possible that the Start Winding has become Open Circuit or a bad connection within that circuit but a quick check with Multimeter will determine that for you.

    By the sounds of it though, it probably wouldn't hurt to strip the entire grinder down (including the motor) for a good clean and refurbish, including new bearings which is cheap insurance. If you're not up for all of this, then I guess you could scan around for a qualified person who has a coffee habit, and then offer them some excellent coffee for their troubles....

    Mal.

  3. #3
    Member
    Join Date
    Sep 2011
    Posts
    33
    Hi Mal,

    Thanks for the elaborate answer. Indeed this is my "test grinder" that I can experiment on, so I will take your advise and refurbish it myself. Should be a nice project for the Xmas break, and it would be useful to put the theoretical knowledge to practise once in a while

    Cheers, Demq
    Dimal likes this.

  4. #4
    kbc
    kbc is offline
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,960
    This happened to me when changing grind from rough to fine too quickly with the Mini E.... You need to change in very small increments and grind a little at each increment along the way. Good luck



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •