Results 1 to 14 of 14
Like Tree18Likes
  • 1 Post By Yelta
  • 1 Post By Caffeinator
  • 1 Post By wattgn
  • 2 Post By mjoyce
  • 3 Post By CafeLotta
  • 1 Post By Javaphile
  • 7 Post By mjoyce
  • 2 Post By Yelta

Thread: Help! (And a warning). Stuck collar on Compak K3

  1. #1
    Senior Member
    Join Date
    Feb 2015
    Location
    Melbourne, Australia
    Posts
    110

    Help! (And a warning). Stuck collar on Compak K3

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all

    First the warning- donít be like me. Iíve neglected cleaning my grinder for an embarrassingly long time. Iím sure my coffee has suffered.

    Today I finally decided to take apart my Compak k3 to clean the burrs. Unfortunately after about 2-3 rotations of the collar the collar / top burr unit is stuck completely fast. I canít budge it.

    Iím sure an expensive and unplanned trip to my local maintenance guy will he needed; unless any of you clever people can take pity and give me advice on how to lubricate / unstick the burrs (and please donít judge me too hardly for neglecting this important job to the extent this extent).

  2. #2
    Senior Member flashpixx's Avatar
    Join Date
    Dec 2013
    Location
    Perth Western Australia
    Posts
    319
    I feel your pain. Somehow my K3P ate some black plastic and destroyed itself. Hope yours is salvageable

  3. #3
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    7,355
    This topic was touched on only a few days ago, post 10 in this thread https://coffeesnobs.com.au/grinders/...attention.html

    Have a look here https://www.home-barista.com/grinder...ng-t40376.html may be of some assistance.

    I suspect your comment re a trip to a repairer will be the way to go.
    level3ninja likes this.

  4. #4
    Senior Member
    Join Date
    Jul 2017
    Posts
    502
    I have seen thread galling on earlier K3 grinders. In some cases, it's sadly the end of tour for them.
    Dimal likes this.

  5. #5
    Senior Member
    Join Date
    May 2005
    Location
    Perth
    Posts
    1,387
    It is certainly galling to have it happen at all. It reminds me I do put a small amount of silicone grease on the Mazzer threads.

    Do they require humane euthanasia or do they ascend to heaven on their own?
    mjoyce likes this.

  6. #6
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    17,570
    Quote Originally Posted by Caffeinator View Post
    I have seen thread galling on earlier K3 grinders. In some cases, it's sadly the end of tour for them.
    Yep, that's what it sounds like...

    Mal.

  7. #7
    Senior Member
    Join Date
    Feb 2015
    Location
    Melbourne, Australia
    Posts
    110
    Have never heard of ďgallingĒ before today. Looks like my Lido will get a workout until a) I can get to my local repair shop to confirm the diagnosis and b) I spend my time on for-sale forums looking for forced upgraditis.


    Fortunately Iím about to go away camping for a few days so am looking forward to using my new-to-me Flair and Bellman steamer anyway!
    Dimal and woodhouse like this.

  8. #8
    Senior Member
    Join Date
    Nov 2014
    Posts
    112
    Had the exact same issue with my old k3. Cross threaded it after a few spins. Required a lot of force to get it undone and assess the damage. Took it to a local machinist who fixed the thread for $20
    Was very frustrating as I had unscrewed it to clean a dozen times without issue

  9. #9
    Senior Member CafeLotta's Avatar
    Join Date
    Jun 2012
    Location
    Melbourne, Vic, Aust.
    Posts
    1,311
    My 2 cents worth. Galling on K3s occurs due to lack of lubrication, it's as simple as that. Any threads left without lube are at risk. The way I have done it since I've had mine is to run a light vertical bead of lube in 4 or so spots around the top burr carrier threads and then use a clean cloth to spread this on all threads by rotating the burr carrier. Use the cloth to remove excess lube, leaving a light coating on all threads. The bottom threads are the most important. When starting the threads on re-assembly, a light touch is needed. If it grabs too much, dis-assemble and add a little extra lube by finger to the lower few threads. Don't get any lube below this as it will collect grinds. Full thread lubrication is the key without over doing it.

    The grease I use is "BIOGREASE BGI-MARLIN-9: FOOD GRADE GREASE H1, NSF & HALAL APPROVED." Others are available and up to you what you're happy to use.

    Quote Originally Posted by mjoyce View Post
    I’m sure an expensive and unplanned trip to my local maintenance guy will he needed; unless any of you clever people can take pity and give me advice on how to lubricate / unstick the burrs (and please don’t judge me too hardly for neglecting this important job to the extent this extent).
    Not judging as it's obviously happened to a few people.

    If it was my grinder, I'd remove the hopper and vacuum out any beans/grinds left inside the grinder as best you can. Then remove the black plastic Grind Adjuster (cover with the numbers on it) from the top burr carrier by unscrewing the 3 allen head screws. Take note of its alignment before removing. Remove the metal feed cone/funnel. Use something like this Inox product https://www.inoxmx.com/products/mx3f...nt-food-grade/ to spray/squirt in the gap between the top burr carrier and the grind chamber in an attempt to wick this lube between the threads. You could leave a while and add some more.

    Re-assemble the parts that were removed. Try gently working the grind adjuster back and forward (only a few mm) in attempt to work the spray lube further down the threads. you may get lucky and be able to unscrew the top burr carrier. If you're not confident doing this, leave it to your service guy. You may recover from the damage or not depending on the severity.

    http://www.compak.es/docs/K3_Touch_Advanced_D.pdf


    P.S. As you're in Melbourne, might be worth getting in touch with "The Coffee Machinist" in Northcote.
    Last edited by CafeLotta; 6th November 2019 at 08:39 AM. Reason: added PDF link. Added P.S. comment
    Dimal, flashpixx and mjoyce like this.

  10. #10
    Senior Member
    Join Date
    Feb 2015
    Location
    Melbourne, Australia
    Posts
    110
    Quote Originally Posted by CafeLotta View Post
    My 2 cents worth. Galling on K3s occurs due to lack of lubrication, it's as simple as that. Any threads left without lube are at risk. The way I have done it since I've had mine is to run a light vertical bead of lube in 4 or so spots around the top burr carrier threads and then use a clean cloth to spread this on all threads by rotating the burr carrier. Use the cloth to remove excess lube, leaving a light coating on all threads. The bottom threads are the most important. When starting the threads on re-assembly, a light touch is needed. If it grabs too much, dis-assemble and add a little extra lube by finger to the lower few threads. Don't get any lube below this as it will collect grinds. Full thread lubrication is the key without over doing it.

    The grease I use is "BIOGREASE BGI-MARLIN-9: FOOD GRADE GREASE H1, NSF & HALAL APPROVED." Others are available and up to you what you're happy to use.



    Not judging as it's obviously happened to a few people.

    If it was my grinder, I'd remove the hopper and vacuum out any beans/grinds left inside the grinder as best you can. Then remove the black plastic Grind Adjuster (cover with the numbers on it) from the top burr carrier by unscrewing the 3 allen head screws. Take note of its alignment before removing. Remove the metal feed cone/funnel. Use something like this Inox product https://www.inoxmx.com/products/mx3f...nt-food-grade/ to spray/squirt in the gap between the top burr carrier and the grind chamber in an attempt to wick this lube between the threads. You could leave a while and add some more.

    Re-assemble the parts that were removed. Try gently working the grind adjuster back and forward in attempt to work the spray lube further down the threads. you may get lucky and be able to unscrew the top burr carrier. If you're not confident doing this, leave it to your service guy. You may recover from the damage or not depending on the severity.

    http://www.compak.es/docs/K3_Touch_Advanced_D.pdf
    thanks for the tips, iíll try this.


    on a follow up note, i had a bad feeling on my camping weekend relying on my Lido 3. the locking ring locked on that too! fortunately a quick google and a few taps with a rubber mallet sorted this out easily.

  11. #11
    Senior Member noidle22's Avatar
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    1,251
    I'd probably advise taking it straight to a fabricator or machine shop and seeing what they could do. Worst case, they'll have to cut away the upper burr carrier. Hoping the outer housing threads can be repaired, you'd just need a new upper burr carrier.

    As others have mentioned, light lubrication of the threads is advisable. Silicone or teflon based is ok.

  12. #12
    Super Moderator Javaphile's Avatar
    Join Date
    Dec 2004
    Location
    Earth!
    Posts
    16,329
    If all else fails and the parts are all metal you can always try putting some dry ice against the inside of the upper burr carrier after insulating the lower areas from it. Then try working the burr carrier off before the cold reaches the outer threads/part of the grinder. Taking all the usual precautions against freezer burns to yourself and breaking things by applying too much force.


    Java "Last resort" phile
    Dimal likes this.
    Toys! I must have new toys!!!

  13. #13
    Senior Member
    Join Date
    Feb 2015
    Location
    Melbourne, Australia
    Posts
    110
    Big shout out to Rick the Coffee Machinist who was able to get this unstuck for me. I enjoyed using the Lido for a few days but will be very happy to plug my grinder back in tomorrow morning!
    Dimal, Javaphile, Mono and 4 others like this.

  14. #14
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    7,355
    Quote Originally Posted by mjoyce View Post
    Big shout out to Rick the Coffee Machinist who was able to get this unstuck for me. I enjoyed using the Lido for a few days but will be very happy to plug my grinder back in tomorrow morning!

    I was wondering! thanks for keeping us informed, pleased to hear the operation was a success.

    PS, don't forget, clean and grease regularly.
    Dimal and mjoyce like this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •