Results 1 to 9 of 9
Like Tree3Likes
  • 2 Post By Andy
  • 1 Post By LeroyC

Thread: Behmor 1600+ exhast cover askew

  1. #1
    Member
    Join Date
    Feb 2008
    Posts
    31

    Behmor 1600+ exhast cover askew

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    I just unpacked my new Behmor roaster. The exhaust cover is at an angle to the device back - the 'upper outer corner' is 6mm further from the device than the inner corner, and reveals part of a circuit board. The circuit board is positioned correctly to the cover and thus at an angle to the device.
    Gentle push/pull does not move the cover.

    1. Is this positioning intentional?

    2. If not, what are the consequences, and should it be rectified?

    3. If so, how will this best be done?

  2. #2
    Super Moderator Javaphile's Avatar
    Join Date
    Dec 2004
    Location
    Earth!
    Posts
    15,855
    No that positioning is not intentional. You should contact the seller about it. If you purchased it from here contact Andy via this Contact Us link which can also be found at the bottom of every page.

    Can you take a picture or two or three and post them here so we can see the problem?


    Java "Exposed boards are bad" phile
    Toys! I must have new toys!!!

  3. #3
    Member
    Join Date
    Feb 2008
    Posts
    31
    Can you take a picture or two or three and post them here so we can see the problem?

    Here is one..
    Attached Images Attached Images

  4. #4
    Guest
    Join Date
    Aug 2015
    Location
    Perth WA
    Posts
    461
    Mine looks the same. What circuit board are you talking about? I don't recall there being any circuit board under the exhaust cover but could be wrong. Often am. Could you take a photo of the circuit board. BTW that cover is only held on by a couple of screws so very easy to remove and refit it that helps.

  5. #5
    CoffeeSnobs Owner Andy's Avatar
    Join Date
    Mar 2004
    Location
    Internet
    Posts
    17,002
    Blog Entries
    1
    Quote Originally Posted by Occam View Post
    I just unpacked my new Behmor roaster. The exhaust cover is at an angle to the device back - the 'upper outer corner' is 6mm further from the device than the inner corner, and reveals part of a circuit board. The circuit board is positioned correctly to the cover and thus at an angle to the device.
    Gentle push/pull does not move the cover.

    1. Is this positioning intentional?

    2. If not, what are the consequences, and should it be rectified?

    3. If so, how will this best be done?

    1: Yes
    2: N/A
    3: N/A

    It's mostly an optical illusion, the cut-out where the exhaust channel meets the "muffler" is larger than the channel, I assume to stop conductive heat transfer. It's perfectly normal and your roaster will work fine.

    Happy roasting!
    Dimal and sprezzatura like this.

  6. #6
    Senior Member LeroyC's Avatar
    Join Date
    Sep 2013
    Location
    Woodend, New Zealand
    Posts
    2,292
    Yeah looks fine to me. Mine looks much the same. As Andy said it's actually pretty straight it's just an optical illusion.
    sprezzatura likes this.

  7. #7
    Member
    Join Date
    Feb 2008
    Posts
    31
    Well, I have measured the "optical illusion" - 6mm wider gap on the right hand side compared to the left hand side.
    Since the exhaust channel (not a circuit board as the bad light led me to believe) is fixed to the cover I was (am?) afraid that exhaust channel is not properly fixed to the rest of the device, which might be problematic.
    But ok, I will try it and at worst have to make a warranty return..

  8. #8
    Senior Member LeroyC's Avatar
    Join Date
    Sep 2013
    Location
    Woodend, New Zealand
    Posts
    2,292
    Quote Originally Posted by Occam View Post
    Well, I have measured the "optical illusion" - 6mm wider gap on the right hand side compared to the left hand side.
    Since the exhaust channel (not a circuit board as the bad light led me to believe) is fixed to the cover I was (am?) afraid that exhaust channel is not properly fixed to the rest of the device, which might be problematic.
    But ok, I will try it and at worst have to make a warranty return..
    Have you tried taking the exhaust cover off to make sure it looks ok underneath? It's easy to do and is part of a 3 monthly cleaning procedure that's in the manual. Could be worth doing, but as I said it doesn't look like there's a problem from your photo, mine looks the same (and MrFF's too by the sound of it). Andy's happy with how it looks which would be good enough for me.

  9. #9
    Super Moderator Javaphile's Avatar
    Join Date
    Dec 2004
    Location
    Earth!
    Posts
    15,855
    Behmor Coffee Roaster
    Quote Originally Posted by Javaphile View Post
    No that positioning is not intentional.
    I stand corrected. I was comparing your pic to my Behmor which is an early US model which has differences to the AUS/Plus model

    Quote Originally Posted by Andy View Post
    1: Yes
    2: N/A
    3: N/A

    It's mostly an optical illusion, the cut-out where the exhaust channel meets the "muffler" is larger than the channel, I assume to stop conductive heat transfer. It's perfectly normal and your roaster will work fine.

    Happy roasting!
    Definitely go with Andy's answer over mine.


    Java "Model what?" phile
    Toys! I must have new toys!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •