Results 1 to 6 of 6
Like Tree2Likes
  • 1 Post By iPatch
  • 1 Post By iPatch

Thread: Newly built Corretto roaster stops spinning

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Posts
    18

    Newly built Corretto roaster stops spinning

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Iíve recently picked up a breville ikon BBM600 bread maker, gutted it and had a friend wire it to a switch. Worked perfectly on the first roast, but after a few minutes after the roast I tried switching the motor on and it would not turn on its own again. Pushing the paddle gets the motor going as usual. Its seems to have a mind of its own. Has anyone had this issue in the past? Im thinking it may be the capacitor getting too hot maybe? but its all a guess.

  2. #2
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    17,564
    Hmmm...

    Sounds like your friend may have bypassed the Start/Run capacitor inadvertently.
    Best to have it checked out by a licensed sparky if your friend isn't so licensed...

    Mal.

  3. #3
    Junior Member
    Join Date
    Jan 2018
    Posts
    18
    He is a licensed electrician, but it did take a little bit of tinkering for him to get the motor spinning in the right direction. Here is a picture of what he didB1790702-7ED5-4AB4-B203-376EF10489F8.jpeg

    After he wired the motor everything ran and stopped as it should with the switch. It was only after the roast that the paddle needed the push to get it going again. At times it would even start turning on its own again.
    Last edited by iPatch; 1 Week Ago at 11:33 AM.
    Dimal likes this.

  4. #4
    Life-long Learner DesigningByCoffee's Avatar
    Join Date
    Aug 2008
    Location
    Millthorpe NSW
    Posts
    2,052
    In all the Breville BBM roasters i've built (3 now) there were two PCBs - one for the display/control board and one for the motor, which housed start capacitors etc. I always left this PCB in place, and basically bypassed the control board PCB only with the switch. Is the BBM600 similar inside?

  5. #5
    Junior Member
    Join Date
    Jan 2018
    Posts
    18
    Yes it does sound like it is the same two PCB setup. I took all of those out, now I think that may have been a mistake. Whoops. The problem with this machine in particular was the agitation would spin clockwise for one minute then stop and spin counter clockwise for a minute, it would keep doing this in one minute intervals. So my though was to just have the motor, run/start capacitor only wired to the switch. I thought the battery looking contraption was the run/start capacitor.

  6. #6
    Junior Member
    Join Date
    Jan 2018
    Posts
    18
    Behmor Coffee Roaster
    Quick update for anyone that may come across this issue with their setup. It turned out the wiring was all done correctly. I pulled the belt system apart from the bottom and lubed the rod that drives the paddle assembly, ran the machine for about half an hour and haven’t had the issue since. The motor ran flawlessly without the belt on. That ruled out any motor issues, I assume the motor didn’t have enough torque to start the paddle spinning due to the dried out parts.
    barlo likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •